Service Outage
Incident Report for PDMS-SP
Resolved
This incident has been resolved.
Posted May 15, 2021 - 00:32 UTC
Investigating
Hi PDMS-SP Users,

We are currently experiencing a service outage with our consumer and service provider solutions. Known impacted services includes - www.obitalk.com and www1.obitalk.com

Thank you for your patience.

Team PDMS-SP
Posted May 14, 2021 - 22:25 UTC
This incident affected: Portal Service.